Fullscreen slowness

Installation and usage on Linux / Installation unter Linux
helinoob
Posts: 11
Joined: 21 Jun 2010 07:42

Fullscreen slowness

Postby helinoob » 27 Jun 2015 21:48

I have noticed that HELI-X in fullscreen mode is sluggish on my machine. It only gives me 15-20 FPS. When the window is maximised (this is only marginally smaller than fullsccreen), I'm getting 35-50 FPS.

I have i7-4770K, a 2560x1440 screen and onboard Intel 4600 graphic (no discrete graphics card), running Gentoo.

Is there any solution?

User avatar
Michael
Posts: 1670
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Fullscreen slowness

Postby Michael » 27 Jun 2015 21:56

I guess it depends on the resolution. You might try a smaller screen resolution in fullscreen.

Michael

User avatar
clel
Posts: 27
Joined: 10 Aug 2014 15:31

Re: Fullscreen slowness

Postby clel » 28 Jun 2015 09:24

What driver are you using? Is it the normal one from the kernel? I am have the same graphics in my i5 and HELI-X does not start for me on Linux.

Regarding your problem, I guess there is a way to check the resolution when running in maximized mode. Is it (almost) the same as running in fullscreen or much lower?

helinoob
Posts: 11
Joined: 21 Jun 2010 07:42

Re: Fullscreen slowness

Postby helinoob » 29 Jun 2015 20:30

Michael wrote:I guess it depends on the resolution. You might try a smaller screen resolution in fullscreen.
Michael


The maximized window is 1352x2560, the fullscreen window is 1440x2560, the difference in pixel count is about 6% but the difference in performance is more than x2. Something is not right...

Edit: I have managed to resize the window to be slightly larger than the full screen resolution and it is still faster than in proper full screen mode. So this is not about the resolution.
Last edited by helinoob on 29 Jun 2015 21:11, edited 1 time in total.

helinoob
Posts: 11
Joined: 21 Jun 2010 07:42

Re: Fullscreen slowness

Postby helinoob » 29 Jun 2015 20:32

clel wrote:What driver are you using? Is it the normal one from the kernel? I am have the same graphics in my i5 and HELI-X does not start for me on Linux.

Regarding your problem, I guess there is a way to check the resolution when running in maximized mode. Is it (almost) the same as running in fullscreen or much lower?


Hi clel,

I'm using the normal driver. Please PM me and I'll try to troubleshoot your issue with HELI-X not starting.
The resolution is indeed nearly the same, minus 6% for the window frame and the panel.

User avatar
clel
Posts: 27
Joined: 10 Aug 2014 15:31

Re: Fullscreen slowness

Postby clel » 29 Jun 2015 20:48

helinoob wrote:
clel wrote:What driver are you using? Is it the normal one from the kernel? I am have the same graphics in my i5 and HELI-X does not start for me on Linux.

Regarding your problem, I guess there is a way to check the resolution when running in maximized mode. Is it (almost) the same as running in fullscreen or much lower?


Hi clel,

I'm using the normal driver. Please PM me and I'll try to troubleshoot your issue with HELI-X not starting.
The resolution is indeed nearly the same, minus 6% for the window frame and the panel.


I managed to start HELI-X now. The problem was caused by an Umlaut in the path and HELI-X does not work inside of paths with umlauts.

Since the resolution of fullscreen and maximized window does not differ much, I think there is a problem with either the driver or HELI-X running things in fullscreen.

I just tested it on my laptop and the FPS were the same in fullscreen as in maximized view (15 FPS). Will test on my home PC this weekend.


Return to “HELI-X on Linux”

Who is online

Users browsing this forum: No registered users and 2 guests