No Joystick found

Installation and usage on Linux / Installation unter Linux
Post Reply
avk2512
Posts: 12
Joined: 08 Oct 2014 19:58

No Joystick found

Post by avk2512 » 08 Oct 2014 20:03

Ubuntu.

Try to launch HELI-X Linux. Controller - Walkera DEVO-7 + UP001 adapter. Connecting to motherboard USB-port.

I see Error:

Code: Select all

andrei@HTPC:~/HELI-X5$ sh ./runHELI-X.sh
Set new path for the resources: /home/andrei/HELI-X5/resources/
Set new path for the user files: /home/andrei/HELI-X5/files/
Linux plugin claims to have found 5 controllers
No Joystick found
What to do?

Code: Select all

andrei@HTPC:~/HELI-X5$ sudo chmod 777 /dev/input/e*
andrei@HTPC:~/HELI-X5$ sudo chmod 777 /dev/input/j*
andrei@HTPC:~/HELI-X5$ ls -l /dev/input
итого 0
drwxr-xr-x 2 root root    140 окт.   8 21:45 by-id
drwxr-xr-x 2 root root    140 окт.   8 21:45 by-path
crwxrwxrwx 1 root root 13, 64 окт.   8 21:27 event0
crwxrwxrwx 1 root root 13, 65 окт.   8 21:27 event1
crwxrwxrwx 1 root root 13, 74 окт.   8 21:27 event10
crwxrwxrwx 1 root root 13, 75 окт.   8 21:45 event11
crwxrwxrwx 1 root root 13, 66 окт.   8 21:27 event2
crwxrwxrwx 1 root root 13, 67 окт.   8 21:27 event3
crwxrwxrwx 1 root root 13, 68 окт.   8 21:27 event4
crwxrwxrwx 1 root root 13, 69 окт.   8 21:27 event5
crwxrwxrwx 1 root root 13, 70 окт.   8 21:27 event6
crwxrwxrwx 1 root root 13, 71 окт.   8 21:27 event7
crwxrwxrwx 1 root root 13, 72 окт.   8 21:27 event8
crwxrwxrwx 1 root root 13, 73 окт.   8 21:27 event9
crwxrwxrwx 1 root root 13,  0 окт.   8 21:45 js0
crw-r----- 1 root root 13, 63 окт.   8 21:27 mice
crw-r----- 1 root root 13, 32 окт.   8 21:27 mouse0

ThomasC
Posts: 196
Joined: 29 Mar 2012 16:29
Location: Germany

Re: No Joystick found

Post by ThomasC » 11 Oct 2014 09:28

try to test your controller using the console, e.g. "jstest /dev/input/js0" and see if Ubuntu recognizes it. If no, you have a problem. UB-001 doesn't work when connected to a USB hub, must be connected directly (but you stated that you have connected it directly, so this should not be an issue)

avk2512
Posts: 12
Joined: 08 Oct 2014 19:58

Re: No Joystick found

Post by avk2512 » 11 Oct 2014 20:03

jstest /dev/input/js0 woks well!
jstest-gui works and calibration also all ok!

avk2512
Posts: 12
Joined: 08 Oct 2014 19:58

Re: No Joystick found

Post by avk2512 » 11 Oct 2014 20:04

Java:

Code: Select all

java version "1.8.0_20"
Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
Java HotSpot(TM) Server VM (build 25.20-b23, mixed mode)

avk2512
Posts: 12
Joined: 08 Oct 2014 19:58

Re: No Joystick found

Post by avk2512 » 11 Oct 2014 21:01

Strange...

I did

Code: Select all

chmod u+rw /dev/input/j*
and joystick found!

But......... graphic rendering VERY SLOW!

What to do to fix graphic slow?

ThomasC
Posts: 196
Joined: 29 Mar 2012 16:29
Location: Germany

Re: No Joystick found

Post by ThomasC » 12 Oct 2014 11:10

Rendering is slow when not using proprietary display drivers. On my old machine with the open source drivers (Ubuntu 12.04, was last year) I got only half of the framerate compared to windows. For full 3D performance see if there are proprietary drivers available for your graphics card. For nVidia this is usually the case, for Intel based cards you might be out of luck.

Have success ;)

ThomasC

avk2512
Posts: 12
Joined: 08 Oct 2014 19:58

Re: No Joystick found

Post by avk2512 » 13 Oct 2014 20:57

Thank you ThomasC, I see.........

ThomasC
Posts: 196
Joined: 29 Mar 2012 16:29
Location: Germany

Re: No Joystick found

Post by ThomasC » 14 Oct 2014 15:21

In case your machine cannot keep up with the framerate, you are stuck with v4 which should perform solidly on slower machines. My old netbook is such a case.

Have fun :)

ThomasC

avk2512
Posts: 12
Joined: 08 Oct 2014 19:58

Re: No Joystick found

Post by avk2512 » 14 Oct 2014 20:16

ThomasC wrote:In case your machine cannot keep up with the framerate, you are stuck with v4 which should perform solidly on slower machines. My old netbook is such a case.

Have fun :)

ThomasC
My Ubuntu running on a machine with AMD A6-3500 APU and integrated graphics core HD 6530D. Drivers seem to be using some ATI Catalyst xvba 12.xxxx, do not remember exactly :( install them to support hardware decoding Full HD content. Card works in 3D-mode for HELI-X first try.

Post Reply