CPU bei 100% - nicht spielbar

Installation and usage on Linux / Installation unter Linux
Post Reply
GerriJay
Posts: 2
Joined: 20 Feb 2014 17:58

CPU bei 100% - nicht spielbar

Post by GerriJay » 20 Feb 2014 18:20

Hallo zusammen!

Ich würde gerne HELI-X auf Linux nutzen. Mit Windows läuft alles wunderbar.
Bei Linux liegt die CPU-Last bei 100% und das Programm ruckelt stark obwohl ich bei 70-80 Frames liege.

Ist das Problem bekannt? Gibt es vllt. eine Lösung?

Im Anhang die Ausgabe von hprof. Vllt. hilft das ja weiter...

Viele Grüße

Edit: Leider wurde die Datei nicht akzeptiert. Hier ist nun die Ausgabe von hprof zu finden: http://pastebin.com/9v5W8dFZ
Edit2:

Code: Select all

java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

User avatar
Michael
Posts: 1613
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: CPU bei 100% - nicht spielbar

Post by Michael » 20 Feb 2014 22:32

... versuche mal, die Framerate zu reduzieren (global Options, OpenGL)

Michael

GerriJay
Posts: 2
Joined: 20 Feb 2014 17:58

Re: CPU bei 100% - nicht spielbar

Post by GerriJay » 21 Feb 2014 16:21

Macht leider keinen Unterschied.

DrGreenthumb
Posts: 11
Joined: 26 Sep 2013 11:23
Location: Germany, Nort Rhine-Westphalia

Re: CPU bei 100% - nicht spielbar

Post by DrGreenthumb » 16 Mar 2014 15:09

Welche Grafikkarte hast du? Und welche Treiber?
Das hört sich so an als würde da Mesa anstatt Hardware OpenGL laufen.

JDz
Posts: 2
Joined: 01 Apr 2014 19:30

Post by JDz » 01 Apr 2014 20:07

I do have a similar Problem that prevents me from buying the simulator.

Using the simulator verison 4.2 works fine but with version 5.0.1405 I expreince complete system hangs for about 0.5 to 1 seconds every 4 to 5 seconds.
The CPU usage is at about 60%. Everything else is left at the default settings except for the heli shadow which has been turned on.
I tried limiting the frame rate to 60 but that didn't help.

System Info:

Code: Select all

Linux Mint 17
Linux-Kernel: 3.11.0-12
Prozessor: Intel I3-2330M CPU @ 2,20GHz x 2
3.8 GB Ram

java version "1.7.0_51"
OpenJDK Runtime Environment (IcedTea 2.4.4) (7u51-2.4.4-0ubuntu0.13.10.1)
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)
Is there anything I can change to make the simulator work smoothly?

If you need more information please let me know how I can assist you.

core
Posts: 20
Joined: 26 Dec 2014 15:23

Re: CPU bei 100% - nicht spielbar

Post by core » 26 Dec 2014 16:34

Yes, Heli-x is resource intense, and maxes out the CPU and GPU thermal loading, with insane FPS when left untouched.
However, when turning on OpenGL, x8 and say 300fps the load is minimal of the CPU, and medium on the GPU.

The program works great for me with:
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)
Linux 3.18-1.dmz.1-liquorix-amd64 #1 ZEN SMP PREEMPT Debian 3.18-1 (2014-12-24) x86_64 GNU/Linu
NVIDIA GK106 [GeForce GTX 650 Ti Boost] Driver 343.36
Intel Pentium G3450 3400 MHz
Desktop: KDE 4.14.2 (Qt 4.8.6)
Either ppm2tx, or the HK Funfly dongle works.
UPDATE:
Had some really nasty crashes, updated to vanilla Debian kernel 3.16.0-4-amd64, updated BIOS from 1.01 to 1.11, still no go.
NVRM: os_schedule: Attempted to yield the CPU while in atomic context
Found that my GPU fan was running too slow, changed "coolbits" to "4" in /etc/X11/xorg.conf which opened the fan controller slider, in Nvidia X-server settings GUI, which I set to 70% or ~ 3000rpm.
GPU maxes out at 42°C. Mobo runs at 27°C.
So far no more crashes.
Last edited by core on 28 Dec 2014 02:06, edited 1 time in total.

earlgrey
Posts: 14
Joined: 24 Jan 2012 20:42

Re: CPU bei 100% - nicht spielbar

Post by earlgrey » 27 Dec 2014 19:59

had similar problems last year with an older nvidia driver when using airports with high resolution.
Problems are gone since using opensuse 13.2 which installs nivida driver version 340 (with java 1.7 openjdk, X version 1.16, kernel 3.16)

Although framerate drops below 60 everything is playable with high resolution on Geforce GTX 550 Ti

Make sure that you use the latest Nvidia driver !

core
Posts: 20
Joined: 26 Dec 2014 15:23

Re: CPU bei 100% - nicht spielbar

Post by core » 28 Dec 2014 02:32

Try playing with the settings that would make the load lighter in ~/HELI-X5/files/Application/ViewSettings.xml file:

<?xml version="1.0" encoding="UTF-8"?>
<project>
<AntialiasingNumber>8</AntialiasingNumber>
<VSync>false</VSync>
<MaxFPSAsInteger>300</MaxFPSAsInteger>
<IsSkyboxMaterialEnabled>true</IsSkyboxMaterialEnabled>
<IsEasyCollision>false</IsEasyCollision>
<IsSuperEasyCollision>false</IsSuperEasyCollision>
<IsEasyThrust>false</IsEasyThrust>
<ShowTimer>true</ShowTimer>
<IsResetAsCrash>false</IsResetAsCrash>
<OctreeSize>30</OctreeSize>
<MaxContactPoints>300</MaxContactPoints>
<SmokeOnOwnHeli>true</SmokeOnOwnHeli>
<SmokeOnVideoHeli>true</SmokeOnVideoHeli>
<SmokeOnRemoteHeli>true</SmokeOnRemoteHeli>
<NoSafetyZone>false</NoSafetyZone>
<OnlineCrash>true</OnlineCrash>
<UseAmbientSound>true</UseAmbientSound>
<UseElasticBladesPitch>false</UseElasticBladesPitch>
<UseElasticBladesCyclic>false</UseElasticBladesCyclic>
<UseDynamicBladeNormals>true</UseDynamicBladeNormals>
<HideMouse>false</HideMouse>
<DeactivateScreenSaver>true</DeactivateScreenSaver>
</project>

Post Reply