Phantom Modes

Tips for the tuning of the helicopters / Tipps für die Einstellung der Helis
Post Reply
ladykate
Posts: 4
Joined: 21 Jan 2014 04:19

Phantom Modes

Post by ladykate » 21 Jan 2014 04:30

I did a search but could not find if Phantom Modes were available with the simulator.

What mode is the Phantom in by default? Can I change (from, say, GPS to ATTI or Manual)?

Thanks very much.

Dan

User avatar
JS1
Posts: 167
Joined: 28 Jun 2013 14:48

Re: Phantom Modes

Post by JS1 » 21 Jan 2014 18:06

All multicopters have currently 2 modes available in Heli-X:
- Stabilized ACC mode on idle-up 1. Like ATTI mode on DJI controllers.
- Manual mode on idle-up 2.
Modelling helis for Heli-X! See model build log here.

ladykate
Posts: 4
Joined: 21 Jan 2014 04:19

Re: Phantom Modes

Post by ladykate » 21 Jan 2014 23:35

Thanks for the quick response. I have one more question (that's it, I promise).

How do I decrease the sensitivity of the sticks? I've tried several things including adjusting most of the variables in the flight mode. I've also tried editing the model pitch gain on the propellers. Right now, my pitch and roll are very sensitive on one of my computers (fine on another) to the point they are almost unusable. Any slight input will result in a 45 degree roll or pitch.

User avatar
JS1
Posts: 167
Joined: 28 Jun 2013 14:48

Re: Phantom Modes

Post by JS1 » 22 Jan 2014 21:30

First re-calibrate you controller in the according Heli-X menu. Maybe stick endpoints were not set correctly before.

If calibrated correctly (check bar travel in calibration display) you can reduce sensitivity by decreasing dual rate (reducing max. effects) and/or increasing expo (less effect around stick mid-points).
Modelling helis for Heli-X! See model build log here.

ladykate
Posts: 4
Joined: 21 Jan 2014 04:19

Re: Phantom Modes

Post by ladykate » 23 Jan 2014 19:56

JS1 wrote:First re-calibrate you controller in the according Heli-X menu. Maybe stick endpoints were not set correctly before.

If calibrated correctly (check bar travel in calibration display) you can reduce sensitivity by decreasing dual rate (reducing max. effects) and/or increasing expo (less effect around stick mid-points).
That didn't work. It is a deadzone issue. The first (painful) increments on the stick were not recognized and then everything would go balls out. However, increasing the deadzone value DID work. I went up to 15%. That was counter-intuitive but I'm now flying on the laptop. Weird.

User avatar
Sky Slicer
Posts: 8
Joined: 08 Jun 2014 21:29
Location: Mesa, AZ USA

Re: Phantom Modes

Post by Sky Slicer » 20 Sep 2015 20:52

Here is what I had to do in order to begin to control the DJI. This seems extreme. I did calibrate the Logitech GamePad F310 in Heli-X. Is there something I am missing? Also, it would be very useful if the P-GPS mode of the Phantom were implemented. In this mode, both attitude and altitude are stabilized. In other words, the left stick controls vertical speed with 0 in the center (where the GamePad 's stick naturally rests).

Image

PS I am a novice, but without the above settings the tiniest perceptible move of the stick causes huge attitude and power changes. It is still way crazy at 70% deflection or more.
Image

User avatar
Sky Slicer
Posts: 8
Joined: 08 Jun 2014 21:29
Location: Mesa, AZ USA

Re: Phantom Modes

Post by Sky Slicer » 07 Oct 2015 22:08

No one can comment on this?
Image

ladykate
Posts: 4
Joined: 21 Jan 2014 04:19

Re: Phantom Modes

Post by ladykate » 07 Oct 2015 22:41

Take a look at what I did. I increased the dead zone so that it wasn't balls to the wall right at first. You can also decrease your D/R. Finally, if you find any success, you can decrease your Expo a bit. Right now, all the power is coming right at the end. On a real system, it doesn't work well that way.

oldpilot
Posts: 1
Joined: 07 Dec 2015 00:57

Re: Phantom Modes

Post by oldpilot » 07 Dec 2015 01:00

Thank you very much. I have a Phantom 2 and this simulator will save me a lot of blades.

Post Reply