Heli-X 3.0/Windows 7 und Multiplayersessions

Flying together - when and where / Gemeinsam fliegen - wann und so
Post Reply
AndyS
Posts: 13
Joined: 07 Dec 2008 16:09

Heli-X 3.0/Windows 7 und Multiplayersessions

Post by AndyS » 08 Aug 2010 10:17

Hallo Leute,
muss mich dann auch leider mal melden.
Habe Heli-X 3.0 und zwei Laptops. Einmal Windws XP und der neue Laptop ist mit Windows 7 Professionel 64-Bit ausgestattet. Habe (noch) auf beiden Rechnern Heli-X drauf will aber auf die Kiste mit Windows 7 umziehen.

Soweit klappt das auch mit HeliX und Windows 7, nur bei den Multiplayer-Sessions habe ich ein Problem. Grundsätzlich sieht der Simulator die Sessions im Internet. Ping geht auch durch. TRACERT liefert auch ein Ergebnis. Nur kommt nach einiger Zeit immer die Meldung "Zu lange auf Server gewartet".

Was mich dabei sehr wundert ist, das Heli-X anscheinend über meinen Loopback-Adapter eine Verbindung aufbauen will.
Dies ist im Log zu erkennen : INFO: create TCPMessageServer .......at Rechnername/10.10.10.10

Das erscheint mir etwas komisch. Auf dem XP-System ist dieses Verhalten von Heli-X nicht so. Da kommt nach kurzer Zeit eine Abfrage welcher Netzwerkadapter genutzt werden soll.

Irgendjemand eine Idee ?

Gruss Andy

AndyS
Posts: 13
Joined: 07 Dec 2008 16:09

Re: Heli-X 3.0/Windows 7 und Multiplayersessions

Post by AndyS » 08 Aug 2010 12:11

So, bin der Sache etwas näher gekommen!

Wenn ich unter XP den Simulator starte und eine Verbingung zu einer Session aufbaue wird im Log eine Liste von IP-Adressen ausgegeben.
Da taucht meine WLAN-Verbindung auf, ein Loopback Adapter und die zwei VPN-Adapter. Anschließend erscheint ein Dialog in dem
ich den Netzwerkadapter auswählen kann.

Wenn ich den Simulator und Windows 7 starte wird nur eine IP-Adresse ausgegeben, nämlich die des Loopback-Adapters.
Da nur ein Adapter zu Verfügung steht wird der Dialog zur Auswahl anscheinend nicht angezeigt. Vermute mal das ist Programmtechnisch so gelöst.

Warum der Simulator nur den Loopback-Adapter findet und nicht meinen WLAN-Adapter ist mir nicht klar. Das ist auch der Fall wenn ich den Loopback-Adapter deaktiviere!

Forsche da mal noch ein wenig weiter.

Mfg.
Andy

AndyS
Posts: 13
Joined: 07 Dec 2008 16:09

Re: Heli-X 3.0/Windows 7 und Multiplayersessions

Post by AndyS » 08 Aug 2010 12:43

So, Problem gelöst!

Hatte das Java Game Networking in Verdacht und mal ein bisschen bei denen im Forum gestöbert.

Habe dann bei mir auf Windows 7 System entdeckt das Eintrag in \system32\drivers\etc\hosts vorhanden ist (10.10.10.10 Rechnername)
Dadruch wird bei der Auflösung des Hostnamens immer der Loopback-Adapter geliefert. Habe das ganze mal auskommentiert und Heli-X 3.0 läuft jetzt auch im Multiplayer-Modus.
Mal schauen was jetzt an anderen Sachen nicht mehr funktioniert ;-)

Gruss Andy

User avatar
Michael
Posts: 1613
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Heli-X 3.0/Windows 7 und Multiplayersessions

Post by Michael » 08 Aug 2010 14:58

Hallo Andy,

Du hast das Problem gut dokumentiert und die richtigen Schlüsse gezogen. Was Du beschreibst, kenne ich von Linux-Systemen. Dass das unter Windows auch so ist, ist mir neu. Vielen Dank.

Übrigens: Dass auch die Loopback-Adresse verwendet wird, macht Sinn, denn dann kann HELI-X zweimal getsartet werden und intern eine Verbindung erstellen. Das ist z.B. sinnvoll, wenn man noch einen zweiten Bidleschirm mit extra Ansicht haben will.


Michael

Post Reply