Cyclic Wobble in Hover Trainer

Installation and usage on Mac OS-X / Installation unter Mac OS-X
Paintboy
Posts: 6
Joined: 19 Nov 2015 20:16

Re: Cyclic Wobble in Hover Trainer

Postby Paintboy » 24 Nov 2015 15:10

I have latest version installed on a 10.11.1 2010 mac pro 8 core with 16 gb of ram and AMD 7950 3gb video ram. and cannot make the any of the heli models wobble irregardless of the algorithm setting.
Mac laptops dont have the greatest video cards in them and the Vram on stock units(unless you have something unusual) doesn't meet the min required OpenGL or video ram requirements for HELI-X current version
you can go to about this mac under the apple logo and get a system report to look at the avail graphics v ram
I think you are seeing some sort of open gl weirdness because the video card cannot handle the frame rates required. would be interest to see what frame rate s you are getting not in hover training but just flying a heli around
even with 3 GB of video ram if i start moving around really quickly i will get frame dropping and stutters occasionally.
as for spending 3000 on a new mac for HELi x i think i might buy a cheep PC instead

User avatar
gyropilot
Posts: 9
Joined: 06 May 2015 04:02
Location: Seaview, WA, USA

Re: Cyclic Wobble in Hover Trainer

Postby gyropilot » 24 Nov 2015 16:40

Paintboy wrote:I have latest version installed on a 10.11.1 2010 mac pro 8 core with 16 gb of ram and AMD 7950 3gb video ram. and cannot make the any of the heli models wobble irregardless of the algorithm setting.

Yah... maybe my little MacBook Pro simply lacks enough horsepower for Heli-X to run smoothly in all circumstances (namely the hover trainer).

The processor is: 2.9 GHz Intel Core i7 (2 cores)
Memory: 16 GB 1600 MHz DDR3

you can go to about this mac under the apple logo and get a system report to look at the avail graphics v ram

It shows: Intel HD Graphics 4000 1536 MB

would be interest to see what frame rate s you are getting not in hover training but just flying a heli around

Flying the TRex 600DFC model around in a photographic scene (Dietersdorf), I'm seeing frame rates ranging from 100 to 300... about 120 seems average. With the heli just sitting on the runway, the frame rate is about 70. I've never noticed any dropouts or stutters in the graphics.

I'll keep digging around to see if there aren't some combination of settings which make the performance better or worse.

Best regards,

John
Blade 120SR (a.k.a.: "The No-Wind Heli")
Blade 450Xv2 w/Microbeast Plus Pro-Edition (a.k.a.: "The Money Pit")
DX6i, DX9
Rotor thumping member of the AMA

Paintboy
Posts: 6
Joined: 19 Nov 2015 20:16

Re: Cyclic Wobble in Hover Trainer

Postby Paintboy » 24 Nov 2015 18:02

my frame rates are approx 300 on ground and average about 350.
i was worried this old card with 3 GB would not work but so far so good, you are working with about half of that....
plus apples OGL implementation has been behind for years now. mac is on ogl2.0 and the PC is on v 4.0
Apple is in the midst of revamping their OGL code to an API called Metal, but that will probably result in a ground up rewrite of the app code to take advantage of
plus it could wind up in the junkyard of apple innovation that never gets used by developers , there are many examples i could site, but wont.
i have been looking at gaming PCs. the hobby industry is just not mac friendly as a general rule.
the new racing quads require a pc to program the flight controllers, flight mode , etc.
I have a new blade 230s that needs a firmware update and the only way is windows ...so i have to find somebody with a laptop, or just get one
if you cant beat um...

User avatar
gyropilot
Posts: 9
Joined: 06 May 2015 04:02
Location: Seaview, WA, USA

Re: Cyclic Wobble in Hover Trainer

Postby gyropilot » 24 Nov 2015 19:42

Paintboy wrote:I have a new blade 230s that needs a firmware update and the only way is windows ...so i have to find somebody with a laptop, or just get one if you cant beat um...

For that kind of thing I have VMWare's Fusion on my Mac and have Windows XP, 7, 8, and 10 in a virtual machines. But none of those will solve my Heli-X cyclic wobbling problem. :(
Blade 120SR (a.k.a.: "The No-Wind Heli")
Blade 450Xv2 w/Microbeast Plus Pro-Edition (a.k.a.: "The Money Pit")
DX6i, DX9
Rotor thumping member of the AMA

Paintboy
Posts: 6
Joined: 19 Nov 2015 20:16

Re: Cyclic Wobble in Hover Trainer

Postby Paintboy » 24 Nov 2015 22:30

Windows XP, 7, 8, and 10 in a virtual machines. But none of those will solve my Heli-X cyclic wobbling problem


nope.... probably makes it worse. even tho you can emulate windows you still have a mac video card, which technically speaking isn't hitting on much in windows either,(if you look at even 800 dollar gaming PCs most of them come with Nvidea cards with anywhere from 4 to 6 gb at the lo end?).... plus splitting system resources to run 2 os so now your 15mb video card is running at probably half speed.
dont get me wrong i have been exclusively mac since 1988, love osx, but the last couple of years this has become NOT the platform for 3d(odd since the mac was once known for its graphic prowess) which is what heli X is is ,a 3d program.hey nothing stays the same , everything changes, besides they would rather sell you a watch :roll:


Return to “HELI-X on Mac OS-X”

Who is online

Users browsing this forum: No registered users and 1 guest