Upgraded to Ver 6 - Trouble trying to get controller to work

Installation and usage on Mac OS-X / Installation unter Mac OS-X
mqowen
Posts: 2
Joined: 17 Feb 2015 01:55

Upgraded to Ver 6 - Trouble trying to get controller to work

Post by mqowen » 17 Feb 2015 02:07

I upgraded to version 6. I still have version 5 loaded and it works fine.

When I set up controller and it starts it sounds like the heli motor or engine is sputtering and I have no collective.

I tried several times to set up controller. Also tried different controller that has previously worked. I do not have the same outcome each time I set it up. It seems to have control over elevator, rudder, sometimes roll. Oother times pitch is the issue.

Ver 5 still works and I also have another sim for Mac OS X and it still works fine.

I have the Yosemite version. I believe I have the correct Java installed.

Has anyone else run into a similar issue.

HeliHajo
Posts: 7
Joined: 18 Apr 2014 12:27

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by HeliHajo » 17 Feb 2015 22:38

Hi!

I had just the same trouble and got somewhat desperate: Oh no! Not right from the start. But then I had this idea: What if I just copied my saved configuration and used that one? Tried and ... worked!
So if you haven't done already: Just start v5, save the controller config to a file. Close v5 and go to v6 and open that file and hopefully you're done as well.

Good luck!
HeliHajo

mqowen
Posts: 2
Joined: 17 Feb 2015 01:55

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by mqowen » 18 Feb 2015 03:39

Thanks so much for the advice.

I got it to work on advice from HeliFreak forum,

"Go into global settings, then input system. Switch to another .jar.
Restart heli-x and try again."

This was the comment and this also worked. I hope someone needing help else sees both these solutions and can get one to work.

Again, Thanks for you comment.

Marc

Hynek
Posts: 2
Joined: 26 Mar 2014 23:50

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by Hynek » 28 Feb 2015 19:05

I had the same problem - could not configure the controller.

I have tried both suggestions from above posts.

Suggestion 1: Go to Global Setting, select Input System and change to another jar file
Did not work for me. There were 3 another .jar files,tried all of them with no success.

Suggestion 2: Copy the configuration file from Heli-X5
This worked for me.
copied files:
Library/HELI-X5/files/controller/Config1.xml
Library/HELI-X5/files/controller/PPM.xml

into: Library/HELI-X6/files/controller/

And then the Helix-6 worked.

Hope it might help

Hynek

evercrash
Posts: 28
Joined: 24 Jul 2012 21:32

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by evercrash » 03 Mar 2015 21:45

I think the X6 transmitter configurator is broken.
Copying the X5 controller xml file worked for me too. Thanks!
Now, I just wish a way to make the idle up switch work as an idle up switch (on a dx9).

User avatar
Love the Lama
Posts: 8
Joined: 30 Nov 2014 15:49
Location: Canada

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by Love the Lama » 21 Mar 2015 22:37

hi, just installed v6. 'had the same issue.
yep, copied the PPM.xml file from the Library folder for v5:
Library/HELI-X6/files/controller/PPM.xml.

v6 is flying fine
Always slowly .. Always surely

SA315B Lama (Walkera4FM200L) RX2618V-D DEVO8s
AS350 Écureuil (RCASuperscale 700) AR7200BX DX9
MAAC#88108

sstyle
Posts: 4
Joined: 13 Sep 2014 21:18

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by sstyle » 24 Apr 2015 07:15

Love the Lama wrote:hi, just installed v6. 'had the same issue.
yep, copied the PPM.xml file from the Library folder for v5:
Library/HELI-X6/files/controller/PPM.xml.

v6 is flying fine
Can you please publish this files? Because there is no download link for 5.0

RubbrDug
Posts: 6
Joined: 03 May 2015 11:23

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by RubbrDug » 03 May 2015 13:01

Yeah, I would like to try that, too. I just installed & licensed V6 and have no older Version.

Thanks for the help!

Thomas

User avatar
Michael
Posts: 1603
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by Michael » 03 May 2015 15:51

Since a week the download is rev 1614. This should have solved the issue.

Michael

evercrash
Posts: 28
Joined: 24 Jul 2012 21:32

Re: Upgraded to Ver 6 - Trouble trying to get controller to

Post by evercrash » 03 May 2015 18:51

I'm excited to try, because I still use ver 5 because of controller issues with ver 6
But rev. 6.0.1612 says it is up to date. So I'm stuck.
Are you saying we should install the whole stuff from scratch to get to 1614?

Post Reply