Sim works but NO rudder function, please help if you can.

Installation and usage on Mac OS-X / Installation unter Mac OS-X
Oldhover
Posts: 6
Joined: 29 Dec 2014 02:50

Sim works but NO rudder function, please help if you can.

Postby Oldhover » 30 Jan 2015 19:15

Trying to configure the sticks on Heli X, but get nothing to move for rudder/tail. I have switched x,y,z,slider around with no success. Maybe I'm not doing something correct, but I'm not a sim expert so maybe somebody can guide me through the process? Here's what I have:
Heli X version 5 on Mac OS
Spectrum DX6i in Heli mode
USB cable interface set to XTR setting

Cyclic works side to side, front to back
Collective works
NO rudder at all.....helicopter flys but no tail control.

Also noticed that I can't check 5th channel in the configure box, not sure what needs to be done here. No HELP function on the screen.

I have had Heli X for a month, waiting for the recommended cable and still can't use it. Kind of frustrating. Thanks to anyone who can help me get it working.

ThomasC
Posts: 209
Joined: 29 Mar 2012 16:29
Location: Germany

Re: Sim works but NO rudder function, please help if you can

Postby ThomasC » 31 Jan 2015 07:40

What kind of USB interface do you have? I don't have a MAC, but in most cases the USB interface can be blamed for problems with missing channels. Try to check the controller functions elsewhere (does the MAC have a system control for this?), and experiment with "configuration" -> "global settings" -> "input system".

Have success :)

Oldhover
Posts: 6
Joined: 29 Dec 2014 02:50

Re: Sim works but NO rudder function, please help if you can

Postby Oldhover » 01 Feb 2015 06:20

I bought the 14 in 1 usb cable from Banggood.com like suggested here, reviewers of this cable say it works on Mac computers. Its been suggested to try another jinput.jar file, but no instructions on where to copy the file to. If I knew where the file was supposed to go, it would probably work as that is what others have done...just wish someone could explain a little further...so far I'm not very happy with Heli X, I thought I bought a sim that was supposed to work. I have this question on another forum but no answers yet there either.

User avatar
Michael
Posts: 1670
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Sim works but NO rudder function, please help if you can

Postby Michael » 01 Feb 2015 09:19

Please send me an email, then we can do it with the version 6. This is more easy.

Michael

greendavegreen
Posts: 2
Joined: 23 Apr 2015 13:18

Re: Sim works but NO rudder function, please help if you can

Postby greendavegreen » 23 Apr 2015 13:25

I have this trouble as well.

Michael and OH, did you get to a resolution for the inability to recognize the 4th channel?

I have the same banngood adapter, a spektrum dx6i, latest java 8 on macbook running 10.10.3

I speak java (and a bit of german!) and am a software developer, so am technical enough to dig in if there is help to be had. I can do hover exercises with Heli-X controlling rudder for me, but beyond that I can't use this for much yet. I would love to get it fully functional and then send send money to developers for a full copy...

I have tried the 4 different versions of the jar, and they all seem to fail to recognize the 4th channel when I'm working with the stick setup panel.... It doesn't look like they are getting readings (initially, the bars reading values for the different channels are jumping around until you calibrate center max/min/direction, on my setup, the 4th channel looks constant)

Dave

User avatar
Michael
Posts: 1670
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Sim works but NO rudder function, please help if you can

Postby Michael » 23 Apr 2015 21:32

I have found a small bug in the axis detection. I hope to make an update available at the weekend. For the moment:

Do the calibration and for the channel whcih does not work, try another axis name by hand in the combo box.

Michael

greendavegreen
Posts: 2
Joined: 23 Apr 2015 13:18

Re: Sim works but NO rudder function, please help if you can

Postby greendavegreen » 25 Apr 2015 01:49

Thanks for the reply Michael. The terminal can be brought up on a mac, but I wouldn't not have found it if I wasn't searching every menu for something that might help me.

I have gotten to a functioning system. I have the banngood adapter mentioend in other threads.

it has multiple settingss on the usb-key, and I chose Phoenix
I have the latest available download on mac 10.10, with java 1.8
what I found that eventually worked was using jinputb8.jar AND FIGURING OUT THAT THE XML SETTINGS FILE HAD an old name and the file not found was causing the error handling to give generic "failed" rather than something useable.

What was happening was that I was trying each of the different jar files to figure out what one would recognize my dx6i when plugged in via the adapter and the only window displayed on the screen at "control setup" time is "No controller found".

Actually, for one of the jar files, it was finding the controller, but it was looking for a configurations file that must have existed in the past (FeiYing-Simulater.........DotXML) the name of what it was looking for was not found, and this caused the "setup" to fail and display the rather generic error.

If the controller is recognized, but the config file is not found to load in defaults, I would suggest a distinct message and some "safe" defaults since the user can calibrate new values for themself.

Withtout the terminal I would have never known that one of the settings was different than the others,
Dave

Thanks much for the other comments in the thread that gave me the ideas to proceed. Just bought my license. hope the money helps!

RubbrDug
Posts: 6
Joined: 03 May 2015 11:23

Re: Sim works but NO rudder function, please help if you can

Postby RubbrDug » 03 May 2015 12:58

Hi to all,

I already bought my license and stumbled into the same problems as the users above. I'm sorry, but I don't understand the solution @greendavegreen provided. Can anybody help me with this?

Thanks

Thomas


Return to “HELI-X on Mac OS-X”

Who is online

Users browsing this forum: No registered users and 1 guest