Heli-X on 10.10

Installation and usage on Mac OS-X / Installation unter Mac OS-X
joepaisley
Posts: 1
Joined: 25 Aug 2014 23:51

Heli-X on 10.10

Postby joepaisley » 25 Aug 2014 23:56

I just tried to run on 10.10 and I get the splash screen but the main display does not appear. Any logs I can send to help with testing?

Thanks.

ThomasC
Posts: 209
Joined: 29 Mar 2012 16:29
Location: Germany

Re: Heli-X on 10.10

Postby ThomasC » 26 Aug 2014 06:28

I assume you run the program on a Mac. I don't know anything about Macs, but I assume that the "status window" also appears on a Mac (It appears under Windows and Linux). The output is not automatically written to a file, but you can use copy/paste to generate such a log and post it here.

Hope it helps

ThomasC

rbakharev
Posts: 3
Joined: 18 Sep 2014 19:02

Re: Heli-X on 10.10

Postby rbakharev » 18 Sep 2014 19:04

Hello, i have problem too. Not start main window. OSx Yosemite. :( please fix it

rbakharev
Posts: 3
Joined: 18 Sep 2014 19:02

Re: Heli-X on 10.10

Postby rbakharev » 18 Sep 2014 19:18

when i opened app with terminal:

Last login: Thu Sep 18 21:58:33 on console
romans-mbp:~ romanbakharev$ /Applications/HELI-X5.app/Contents/MacOS/launch.command ; exit;
Set new path for the resources: /Users/romanbakharev/Library/HELI-X5/resources/
Set new path for the user files: /Users/romanbakharev/Library/HELI-X5/files/
No Joystick found
Exception in thread "LWJGL Renderer Thread" java.lang.UnsatisfiedLinkError: Can't load library: /Users/romanbakharev/Library/HELI-X5/liblwjgl.dylib
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1817)
at java.lang.Runtime.load0(Runtime.java:809)
at java.lang.System.load(System.java:1083)
at org.lwjgl.Sys$1.run(Sys.java:70)
at java.security.AccessController.doPrivileged(Native Method)
at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
at org.lwjgl.Sys.loadLibrary(Sys.java:95)
at org.lwjgl.Sys.<clinit>(Sys.java:112)
at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:206)
at java.lang.Thread.run(Thread.java:745)

rbakharev
Posts: 3
Joined: 18 Sep 2014 19:02

Re: Heli-X on 10.10

Postby rbakharev » 21 Sep 2014 17:56

Somebody help please

Hynek
Posts: 2
Joined: 26 Mar 2014 23:50

Re: Heli-X on 10.10

Postby Hynek » 17 Oct 2014 21:14

Hi,

I have installed new operating system Yosemite (10.10) and now I cannot use Helix.
When I clicked on Helix to start it, I got a message from the system that to use this application I have to install Java 8 from Oracle site.
I did install Java 8 run time system from the Oracle site, but nothing changed, I am getting the same message.

Any advise?

Thanks
Hynek

Solution from Michael which worked for me:
Steps:
1. I have installed Java SDK from Oracle site
2. I have deleted the folder HELI-X5 (it is in the user's Library)
3. I did run the HeliX - it did start, but it did not launch the main screen.It did recreate the HELIX-5 folder.
3. In the HELIX-5 folder, I duplicated the file "liblwjgl.jnilib" and renamed the duplicate to "liblwjgl.dylib"
4. Started Helix, now it started properly, as "DEMO" version. Using an "Option" menu, I register myself.
5. After these steps, the Helix now works for me

Thanks Michael for the help.
Hynek
Last edited by Hynek on 20 Oct 2014 00:33, edited 1 time in total.

heliquax
Posts: 3
Joined: 17 Oct 2014 22:06

Re: Heli-X on 10.10

Postby heliquax » 17 Oct 2014 22:08

Dear all,

I have the same problem :(

Best regards,


Hynek wrote:Hi,

I have installed new operating system Yosemite (10.10) and now I cannot use Helix.
When I clicked on Helix to start it, I got a message from the system that to use this application I have to install Java 8 from Oracle site.
I did install Java 8 run time system from the Oracle site, but nothing changed, I am getting the same message.

Any advise?

Thanks
Hynek

bwing
Posts: 4
Joined: 18 Oct 2014 10:24

Re: Heli-X on 10.10

Postby bwing » 18 Oct 2014 10:28

Little bit different for me.
I installed the Java from the Oracle Side after the request. Now Heli-X starts, opens the statistics window but no main window.

Best Regards
Bernhard

User avatar
Michael
Posts: 1670
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Heli-X on 10.10

Postby Michael » 18 Oct 2014 11:32

Hello

there seem to be some issues with Moc AS X 10.10. For the Moment, please try the following:

1. Delete the Folder HELI-X5 in your peroinal libraray Folder.
2. Download and install JavaJRE or SDK from Oracle.
3. Try to run the HELI-X app.
4. If it still Dows not work: Copy liblwjgl.jnilib in your HELI-X5 folder of the peronal libarary folder to liblwjgl.dylib in the same folder.

Does it work?

Michael

bwing
Posts: 4
Joined: 18 Oct 2014 10:24

Re: Heli-X on 10.10

Postby bwing » 18 Oct 2014 11:42

Hi Michael,

when you said "Softlink" in your mail from last night, I made an alias which didn't help.

Now I made a copy and this works!!

Thanks for your support.
Bernhard


Return to “HELI-X on Mac OS-X”

Who is online

Users browsing this forum: No registered users and 1 guest